Last updated: Fetched just now
Increased HTTP 500 Errors in Querétaro, Mexico
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Monitoring
A fix has been implemented and we are monitoring the results.
- Identified
Cloudflare is investigating an increased level of HTTP 500 errors in Querétaro, Mexico. We are working to analyse and mitigate this problem. More updates to follow shortly.